Ticket #1395 (closed defect: fixed)

Opened 3 years ago

Last modified 2 years ago

"Import Error: cannot import name UnicodeMultiDict" when installing ckan from source

Reported by: seanh Owned by:
Priority: awaiting triage Milestone:
Component: ckan Keywords:
Cc: dread Repository: ckan
Theme: none


At the paster db init command when installing ckan from source I get the error "Import Error: cannot import name UnicodeMultiDict?" (happens with both ckan 1.4.2 and today's latest bleeding edge code, on Ubuntu 10.04.3).

UnicodeMultiDict? has been removed in a recent version of python-webob, and the pip install ... lucid_missing.txt causes a too-new version of python-webob to be installed into ckan's virtualenv (the new webob gets installed as a dependency of formalchemy).

I manually did pip uninstall webob and then ran paster db init again and it worked.

Change History

comment:1 Changed 3 years ago by seanh

The exact command that introduced the too-new webob into my virtualenv was:

pip install --ignore-installed -r pyenv/src/ckan/requires/lucid_missing.txt -r pyenv/src/ckan/requires/lucid_conflict.txt

comment:2 Changed 3 years ago by dread

  • Cc dread added

comment:3 Changed 3 years ago by dread

This problem is mentioned here: http://docs.ckan.org/en/latest/test.html but you're right, it really should be solved in the install instructions.

comment:4 Changed 2 years ago by dread

  • Status changed from new to closed
  • Resolution set to fixed

I added this to the instructions a few days ago to fix this issue for the 1.5 release:

       pip install webob==1.0.8

Cheers Sean.

Note: See TracTickets for help on using tickets.