Ticket #1405 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

You can add a package twice to a group

Reported by: [email protected] Owned by: dread
Priority: minor Milestone: ckan-sprint-2011-11-07
Component: ckan Keywords:
Cc: dread Repository: ckan
Theme: none

Description (last modified by dread) (diff)

To reproduce (from Jonathan Gray):

  • I go to add an item to the group
  • As I type, I get autocomplete options (cool!)
  • When I click on one, it adds this, and copies the same autocomplete option in the box
  • When I click submit, it seems to add the item twice
  • On the main group page I think it just shows up once, but when I click edit it shows two identical boxes, both ticked - and the count includes two copies of the same item

Basically the problem is allowing the same package associated multiple times with a group.

This is an issue on CKAN 1.5b and probably earlier.

Change History

comment:1 Changed 3 years ago by dread

  • Cc jwyg added
  • Description modified (diff)
  • Reporter changed from dread to jwyg

comment:2 Changed 3 years ago by dread

comment:3 Changed 3 years ago by dread

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in cset:e68926926bee for release 1.5.

David looked for duplicates on thedatahub.org and found one - http://thedatahub.org/group/lodcloud with http://thedatahub.org/dataset/didactalia. I fixed that by opening the dataset, editing, saving.

Note: See TracTickets for help on using tickets.