Ticket #2406 (new defect)

Opened 2 years ago

Last modified 23 months ago

Errors in source install doc

Reported by: markw Owned by: kindly
Priority: awaiting triage Milestone: ckan-v1.9
Component: ckan Keywords:
Cc: Repository: ckan
Theme: none

Change History

comment:1 Changed 2 years ago by toby

I installed CKAN yesterday afternoon from source, using the instructions at


Most things worked pretty smoothly and, luckily, when they didn't I was lucky enough to have David Raznick on hand to help sort them out. As a result I've made the following notes on where the doc could be improved.

For some ghastly reason I am running Linux Mint, which is some variant of Ubuntu. It's not 10.04, so no package, hence the source install.

Sec 2: Not wanting a mysterious file called 'pyenv' in my home directory, I created a directory ~/ckan and typed 'virtualenv pyenv' from there. Everything worked fine. But if I had needed the 'tip' it would have been a little confusing. It would also be worth reminding the user that the dubious package is one they've supposedly just installed, so if that went OK, they won't need to worry about this.

The tip also isn't clear about under what circumstances I'd need to do the 'easy_install pip' - I didn't need to (is that also only when python-virtualenv is missing?)

Sec 4: This worked, but the example command for installing a particular version is confusing. It says it is for 1.5.1, but replacing '1.5.1' with '1.7' fails because there is a rogue 'c' in the command.

Probably it would be better to use the latest version (1.7) as the example anyway. Or is there a way of asking for the latest released version?

I understand this checks out the whole Git repository with all history

  • I can't imagine why I'd need to do this to build a particular

version. But David assures me it's very sensible.

Sec 6: This worked, but it wasn't very clear what the purpose of the 'List existing databases' step was.

Sec 8: So now I had to try to get Solr working using the instructions at


This didn't work at all, in ways I can't now remember, to do with Java. In the end David suggested using Tomcat rather than Jetty (don't ask me what these do, but they have something to do with getting Solr to work ...) and this turned out to be much more straightforward to install and get working, with two caveats (below). David suggested maybe Tomcat should be the default suggested in this doc.

  • One problem with Jetty was to do with using the wrong version of

Java, which seemed to be fixed using "sudo update-alternatives --config java". It didn't fix Jetty - not sure if it would also have been needed with Tomcat.

  • Soft linking the schema file didn't work - it seems Tomcat doesn't

like soft links. We made a copy.

After this everything worked, and I now have my very own CKAN. Hurrah!


comment:2 Changed 2 years ago by toby

The 'post-installation setup' instructions at


claim to be for either package or source installations, but only work as stated if you have done a package installation. E.g. after a source install, "paster --plugin=ckan user add admin --config=/etc/ckan/std/std.ini" doesn't work (the ini file is somewhere completely different), but just typing "paster user add admin" from the ckan directory is fine.

The instructions should also mention that the virtual environment should be activated.


comment:3 Changed 23 months ago by kindly

  • Milestone set to ckan-v1.8

comment:4 Changed 23 months ago by kindly

  • Milestone changed from ckan-v1.8 to ckan-v1.9
Note: See TracTickets for help on using tickets.