Ticket #2575 (closed enhancement: fixed)

Opened 23 months ago

Last modified 22 months ago

Licenses have i18n issues (was Inconsistent language on license dropdown)

Reported by: amercader Owned by: toby
Priority: awaiting merge Milestone: ckan-v1.9
Component: ckan Keywords: i18n
Cc: [email protected]…, [email protected] Repository: ckan
Theme: none

Description (last modified by toby) (diff)

License titles at least for some of them need translating. This wants to be done in a more efficient and simple manner than currently exists.

the original problem was:

The license dropdown on the dataset form shows titles in Swedish by default. Changing the language seems to default to English, but after refreshing the page a couple of times it shows a wrong language again.

Thanks to pudo for reporting.

Change History

comment:1 Changed 23 months ago by toby

@adria,

Do you have a url or some more info as I can't reproduce this

comment:2 Changed 23 months ago by toby

wtf I never added that I did write in an hour ago fg trac

comment:3 Changed 23 months ago by toby

  • Owner set to toby
  • Status changed from new to accepted
  • Description modified (diff)
  • Summary changed from Inconsistent language on license dropdown to Licenses have i18n issues (was Inconsistent language on license dropdown)

comment:4 Changed 22 months ago by toby

  • Milestone changed from ckan-v1.8 to ckan-v1.9

This should now have a fix

do a proper fix for 1.9 - needs a more thought out approach and quite a bit of re-factoring of that bit of code

comment:5 Changed 22 months ago by toby

  • Priority changed from major to awaiting merge

comment:6 Changed 22 months ago by toby

  • Status changed from accepted to closed
  • Resolution set to fixed

merged for 1.8

Note: See TracTickets for help on using tickets.