Ticket #283 (closed enhancement: wontfix)

Opened 4 years ago

Last modified 3 years ago

Manage deletions of unwanted packages

Reported by: dread Owned by: rgrp
Priority: awaiting triage Milestone:
Component: ckan Keywords:
Cc: Repository: ckan
Theme: none

Description (last modified by rgrp) (diff)

Use case

As a user I want to notify the CKAN admins of a spammed or unsuitable package for deletion.

Suggested solution

In the package view side-bar, there is a note: "To have this package completely removed, contact the [ca.ckan.net administrators [email protected]…]."

Other solutions

A more complicated solution would be to allow packages to be tagged for deletion, which would auto-alert administrators, and allow easier administration of this. But this might be overkill.

c.f. http://en.wikipedia.org/wiki/Deleting_an_article

Change History

comment:1 Changed 4 years ago by rgrp

  • Description modified (diff)

Can I *strongly* suggest we just use the existing perfectly-good-system for flagging stuff called "tags" :)

I suggest we have agree in the community a standard set of "meta" tags for this kind of stuff. E.g. i'm already using the "duplicate" tag for marking duplicates (I also add in notes the link to duplicate package but that's optional). So I suggest we:

  1. Create "reserved" tag prefix "meta"
  2. Create following specific tags (suggestions/comments welcome):
  • meta.duplicate - duplicate of another package. If possible

indicate in notes or an extras field (to be decided) what it is duplicate of

  • meta.spam

Editors can then just visit http://ckan.net/tag/read/meta.spam and work through list of packages there.

If "push" notifications are required as well as "pull" then I suggest this be put in an external service (e.g. rss2email) rather than integrated into CKAN core.

comment:2 Changed 3 years ago by dread

  • Repository set to ckan
  • Status changed from new to closed
  • Theme set to none
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.